GLS - problems creating a shipment

Incident Report for Picqer

Resolved

This issue is resolved.
Posted May 26, 2026 - 15:15 CEST

Identified

Service has degraded again since 14:00. GLS confirms the outage, they are working on a solution.
Posted May 26, 2026 - 14:05 CEST

Monitoring

The GLS service has recovered since 13:45. We are monitoring the shipments and will resolve this incident accordingly.
Posted May 26, 2026 - 13:56 CEST

Identified

Users can experience problems while creating a GLS shipping label. We've contacted GLS for more information and will post updates here.
Posted May 26, 2026 - 13:43 CEST