Problem opening "Singles" batches

Incident Report for Picqer

Resolved

This issue has been resolved.
Posted Apr 17, 2025 - 12:51 CEST

Investigating

Currently "singles" batches cannot be viewed. We are looking into this, and will resolve this issue quickly.
Posted Apr 17, 2025 - 12:47 CEST