The QLS service has recovered since 10:45 significantly. We are monitoring the shipments and will resolve this incident accordingly. QLS has also confirmed a long-term fix by tomorrow morning.
Posted Dec 08, 2025 - 11:02 CET
Identified
QLS confirms the outage for DPD en DHL Germany, they are working on a solution.
Posted Dec 08, 2025 - 11:01 CET
Investigating
Users can experience problems while creating a QLS shipping label. We've contacted QLS for more information and will post updates here.