Picqer app [Android] not working

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 09:18 CET

Monitoring

The issue has been resolved. If you are still experiencing problems when opening the Picqer app, please delete the app in the Play Store and then reinstall it.
Posted Feb 20, 2026 - 09:04 CET

Identified

We have identified the issue. It only occurs to Android app version 2.10.3. We are working on a solution.
Posted Feb 20, 2026 - 08:56 CET

Investigating

There are currently problems with the Picqer app on Android devices. Users are unable to open the app. We are investigating this issue with high priority and will post updates here.
Posted Feb 20, 2026 - 08:15 CET