Sendcloud: elevated errors for shipping labels

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 16:13 CEST

Monitoring

Sendcloud has resumed normal operations again since 16:00
Posted Sep 10, 2025 - 16:11 CEST

Update

Posted Sep 10, 2025 - 15:42 CEST

Identified

Error levels are again high since 15:30, we are updating Sendcloud about this.
Posted Sep 10, 2025 - 15:40 CEST

Monitoring

We have informed Sendcloud about the errors and are observing normal operations again since 15:23.
Posted Sep 10, 2025 - 15:25 CEST

Investigating

We are observing a high error-rate for Sendcloud shipping labels since 15:05 and are looking into this.
Posted Sep 10, 2025 - 15:19 CEST