PrintNode - Unable to connect and print labels

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 08:41 CET

Monitoring

PrintNode is operational again, you can now resume printing your documents in Picqer via PrintNode.
Posted Nov 18, 2025 - 08:39 CET

Update

We have contacted PrintNode regarding the issue and are waiting for their response. In the meanwhile, printing shipping labels in Picqer can be done by opening and manually printing the PDF file.
Posted Nov 18, 2025 - 08:29 CET

Investigating

Currently, we are hearing reports of PrintNode being unable to connect and print labels. We are contacting PrintNode about this issue.
Posted Nov 18, 2025 - 08:20 CET