GLS - problems creating a shipment

Incident Report for Picqer

Resolved

GLS implemented a solution. It is now possible to create shipping labels again.
Posted Apr 07, 2026 - 11:30 CEST

Identified

We are in contact with GLS. They are working on a solution. We keep you updated.
Posted Apr 07, 2026 - 11:01 CEST

Investigating

Users can experience problems while creating a GLS shipping label. We've contacted GLS for more information and will post updates here.
Posted Apr 07, 2026 - 10:10 CEST