DHL shipments error
Incident Report for Picqer
Resolved
This issue is resolved. It is possible to create DHL shipments again.
Posted Nov 25, 2024 - 11:46 CET
Investigating
There are currently issues with creating DHL shipment labels in Picqer. We see that in some cases when you create the label in Picqer, the shipment label is available in DHL itself but not in Picqer. We'll keep you informed about further updates.
Posted Nov 25, 2024 - 09:59 CET