Picqer - Creating shipment is not possible

Incident Report for Picqer

Resolved

This incident has been resolved. We are sorry for the inconvenience.
Posted Nov 17, 2025 - 13:27 CET

Monitoring

It's possible to create shipments again. We'll continue to monitor this.
Posted Nov 17, 2025 - 12:55 CET

Investigating

There are currently problems with creating shipments in Picqer.

We are investigating this issue and will post updates here.
Posted Nov 17, 2025 - 12:45 CET