We are currently experiencing a technical issue, we are investigating this issue with high priority.

Incident Report for Picqer

Resolved

Picqer's performance is back to normal. We are still closely monitoring performance.
Posted Jun 12, 2025 - 15:19 CEST

Investigating

We are currently experiencing a technical issue, we are investigating this issue with high priority.
Posted Jun 12, 2025 - 15:06 CEST