DPD - problems creating a shipping label

Incident Report for Picqer

Resolved

DPD has notified us that the issue has been resolved.
Posted Nov 11, 2025 - 14:32 CET

Update

DPD has confirmed they are aware of the issue, and are currently investigating.
Posted Nov 11, 2025 - 13:29 CET

Investigating

Users can experience problems while creating a DPD shipping label. We've contacted DPD for more information and will post updates here.
Posted Nov 11, 2025 - 13:12 CET