Sendcloud - Shipments error

Incident Report for Picqer

Resolved

This issue is resolved.
Posted Feb 28, 2025 - 10:25 CET

Monitoring

Sendcloud implemented and released a fix. We will continue to monitor the performance to ensure the service is fully restored.
Posted Feb 28, 2025 - 09:55 CET

Identified

Sendcloud stated that they identified the issue and are implementing a fix. For more information: https://status.sendcloud.com/
Posted Feb 28, 2025 - 09:34 CET

Investigating

Several users experienced time-outs while creating Sendcloud shipments. We've contacted Sendcloud for more information.
Posted Feb 28, 2025 - 09:31 CET