GLS - problems creating a shipment

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 14:07 CET

Monitoring

A fix has been implemented by GLS. Most users are able to create shipping labels again. We are monitoring the results.
Posted Feb 27, 2026 - 12:56 CET

Investigating

Users can experience problems while creating a GLS shipping label. We've contacted GLS for more information and will post updates here.
Posted Feb 27, 2026 - 08:49 CET