DPD shipments error
Incident Report for Picqer
Resolved
This problem is solved. It is now possible again to create DPD shipment labels.
Posted Nov 11, 2024 - 11:20 CET
Identified
DPD currently has problems creating shipments. We'll update you as soon as we know more.
Posted Nov 11, 2024 - 09:47 CET