Picqer is slower than usual

Incident Report for Picqer

Resolved

The issue has been resolved, Picqer is working properly again. We apologize for the inconvenience.
Posted Mar 11, 2025 - 09:22 CET

Update

The delay affects multiple functions in Picqer. Including creating the export and printing labels.
Posted Mar 11, 2025 - 09:06 CET

Investigating

Picqer is slower than usual. We are currently investigating this issue.
Posted Mar 11, 2025 - 09:00 CET