PostNL storing
Incident Report for Picqer
Resolved
We zien geen problemen meer bij het maken van zendingen via PostNL.
Posted 9 months ago. Oct 23, 2018 - 18:55 CEST
Investigating
PostNL lijkt op dit moment een storing te hebben. Je kan daardoor mogelijk geen PostNL labels aanmaken.
Posted 9 months ago. Oct 23, 2018 - 18:13 CEST