DPD - problems creating a shipment

Incident Report for Picqer

Resolved

This issue is resolved. It is possible to create DPD shipments again.
Posted Sep 03, 2026 - 17:21 CEST

Monitoring

The DPD service has recovered since 16:44. We are monitoring the shipments and will resolve this incident accordingly.
Posted Sep 03, 2026 - 16:59 CEST

Investigating

Users can experience problems while creating a DPD shipping label. We've contacted DPD for more information and will post updates here.
Posted Sep 03, 2026 - 16:32 CEST