GLS - shipments error

Incident Report for Picqer

Resolved

This issue is resolved. It is possible to create GLS shipments again.
Posted Mar 10, 2025 - 16:33 CET

Investigating

Several users experienced time-outs while creating GLS shipments. We've contacted GLS for more information.
Posted Mar 10, 2025 - 13:02 CET