MyParcel - problems creating a shipment

Incident Report for Picqer

Resolved

This issue is resolved. It is possible to create MyParcel shipments again.
Posted Mar 30, 2026 - 19:58 CEST

Identified

MyParcel confirms the outage despite the fact that some labels can be created. They are working on a solution. We keep monitoring the outage.
Posted Mar 30, 2026 - 17:14 CEST

Investigating

Users can experience problems while creating a MyParcel shipping label. We've contacted MyParcel for more information and will post updates here.
Posted Mar 30, 2026 - 15:31 CEST