DPD - problems creating a shipping label

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 11:39 CET

Monitoring

The DPD service has recovered since 11:32. We are monitoring the shipments and will resolve this incident accordingly.
Posted Nov 11, 2025 - 11:36 CET

Identified

The outage is confirmed by the intermediary of DPD.
Posted Nov 11, 2025 - 11:33 CET

Investigating

Users can experience problems while creating a DPD shipping label. We've contacted DPD for more information and will post updates here.
Posted Nov 11, 2025 - 11:25 CET