DPD - problems creating a shipment

Incident Report for Picqer

Update

DPD is still investigating the issue, there is currently no estimated time for when the issue will be resolved.
Posted Jul 21, 2026 - 09:15 CEST

Investigating

Users can experience problems while creating a DPD shipping label. We've contacted DPD, they have confirmed they are aware of the issue and are looking for a solution.
Posted Jul 20, 2026 - 13:31 CEST