DPD - problems creating a shipment

Incident Report for Picqer

Update

DPD is still working to resolve the issue and has identified the cause, however, there is no estimated time for when it will be resolved.
Posted Jun 22, 2026 - 16:04 CEST

Update

DPD confirms again that they are working on a fix, but also note that they don't have an estimation time for recovery at this moment.
Posted Jun 22, 2026 - 11:04 CEST

Update

DPD is still working on the issue, they have not shared additional information or an ETA for recovery yet.
Posted Jun 22, 2026 - 10:38 CEST

Identified

DPD confirms the outage: DPD Connect is down. They are working on a solution.
Posted Jun 22, 2026 - 07:25 CEST

Investigating

Users can experience problems while creating a DPD shipping label. We've contacted DPD for more information and will post updates here.
Posted Jun 22, 2026 - 07:01 CEST