DPD - shipments error

Incident Report for Picqer

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 10:04 CEST

Monitoring

We’re now seeing successful shipments with DPD again. We’ll keep monitoring the situation to make sure everything remains stable.
Posted Apr 12, 2025 - 18:28 CEST

Investigating

DPD currently has problems creating shipments. We'll update you as soon as we know more.
Posted Apr 12, 2025 - 11:28 CEST