GLS - problems creating a shipping label

Incident Report for Picqer

Resolved

This outage has been resolved and we have observed no errors since.
Posted Oct 29, 2025 - 22:29 CET

Investigating

Users can experience problems while creating a GLS shipping label. We've contacted GLS for more information and will post updates here.
Posted Oct 29, 2025 - 17:00 CET