Picqer is slower than usual

Incident Report for Picqer

Resolved

Picqer's performance is back to normal. If you still perceive any slowness, please send us a message via support@picqer.com.
Posted Jun 10, 2025 - 15:52 CEST

Monitoring

Picqer's performance is back to normal. We are closely monitoring performance.
Posted Jun 10, 2025 - 14:07 CEST

Update

We are continuing to investigate this issue.
Posted Jun 10, 2025 - 13:18 CEST

Investigating

Picqer is operating slower than usual. As a result, it can take a bit longer for orders to move from status "concept" to "processing". We are investigating this issue with high priority.
Posted Jun 10, 2025 - 13:15 CEST
This incident affected: Picqer (Picqer Core).