Problems with creating shipments in Picqer

Incident Report for Picqer

Resolved

The issue has been resolved. We are sorry for the inconvenience.
Posted Jun 13, 2025 - 11:08 CEST

Monitoring

A fix has been implemented, we are monitoring the results. Please reach out to support@picqer.com if you're still having problems creating shipments.
Posted Jun 13, 2025 - 10:57 CEST

Identified

There are currently problems with creating shipments in Picqer. We are working on a fix and expect this issue to be solved quickly.
Posted Jun 13, 2025 - 10:39 CEST
This incident affected: Picqer (Picqer Core).