Problems with opening purchase orders in Picqer

Incident Report for Picqer

Resolved

The issue has been resolved. We are sorry for the inconvenience.
Posted Jul 29, 2025 - 10:53 CEST

Identified

There are currently problems with creating shipments in Picqer. We are working on it and expect this issue to be solved quickly.
Posted Jul 29, 2025 - 10:42 CEST