Telefonisch onbereikbaar
Incident Report for Picqer
Resolved
We zijn weer telefonisch bereikbaar.
Posted 9 months ago. Oct 26, 2017 - 12:33 CEST
Identified
Door een storing bij onze telefonieleverancier, zijn we op dit moment telefonisch onbereikbaar. Je kan ons wel via e-mail op info@picqer.com bereiken. Onze excuses voor het ongemak.
Posted 9 months ago. Oct 26, 2017 - 11:29 CEST