Telefonisch niet bereikbaar
Incident Report for Picqer
Resolved
Het probleem bij de telefonie provider is opgelost, we zijn weer telefonisch bereikbaar.
Posted 7 months ago. Dec 30, 2016 - 09:50 CET
Identified
Vanwege een storing bij onze telefonie provider, zijn we op dit moment telefonisch niet bereikbaar. We zijn wel bereikbaar via e-mail op info@picqer.com.
Posted 7 months ago. Dec 30, 2016 - 09:20 CET