Telefonisch onbereikbaar
Incident Report for Picqer
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 20, 2018 - 08:02 CET
Identified
Op dit moment is er een storing bij onze telefonieleverancier. Daardoor zijn we telefonisch niet bereikbaar. Je kan ons wel per e-mail bereiken op info@picqer.com
Posted 4 months ago. Jan 19, 2018 - 11:37 CET